The BIG project thread

Show off your work! Anything from final results to full start-to-finish project journals.



Top Contributor
Posts: 5543
Joined: Tue Sep 16, 2008 1:17 pm
Location: Pahrump NV.
Country:
USA
PostPosted: Sun Nov 28, 2021 9:51 am
Well I changed all the Plugs and 1 coil that continues to fault a miss cyl 7 ...no help code was back with same miss and codes NO JOY!
So I Swapped the Ionic moduals same, Problems same codes no changes. At least I know they aren't causing the problem.

Took too deep thought overnight, must be an Vacuum leak or low on compression I thought hmmm... sleep on it.
So yesterday In the morning I took too disassembling the Top end and found that the cylinder I had misfire on and had changed the coil on I failed to properly plug the new coil in correctly and wasn't making full contact MY BAD! How I managed that I am unsure? I assembled all of the others correctly changing all the spark plugs????

But I was already half way through removing the Top end and rather than put it all back together to try it again I decided to continue as I had already discovered a vacuum line that was off causing a leak so far, so I continued with other side and sure enough I discovered another Major vacuum leak! on cyl 3 that would occasionally throw a fault code on computer but was never consistent as cyl 7, on cyl 3 One of the rubber boots from throttle body to the intake plenum was incorrectly installed by some one else at some time and was folded over. all good finds.

So I decided to continue by removing all 10 injectors marked them for trouble shooting and will send them out for cleaning flow check and leak check. I will take them over to a Place that cleans flows and rebuilds injectors curious to see what the number 7 does I have a feeling it may leak or has a bad pattern will see.

I will also be changing the Thermostat while the Top end is off as one of the codes I was getting intermittently everyone on a BMW forum says is caused by the Thermostat sticking open.
It cant be changed without removing the Top end Plenum and its not a Job I want to do more than once a year that's for sure Not a Hard job BUT definitely a tedious and Time consuming job. I am hoping for the best when I get it all back together.
Fairly certain it should run good when I get it all back together. Then I can worry about some other minor problems such as the one headlight and a Parking assist problem a few other minor cosmetic problems.
The headlight is a Major problem in cost alone used headlight assembly's are not cheap new units are north of $1500, damaged used units start in the $400 range for parts!
I had no idea they were so expensive.
This is not my current concern at this time, I figured it would be a $300-$600 problem when I bought the car. I have no idea whats going on with the Park assist as no codes are showing up just the on board computer saying there is a fault but doesn't say what it is.
Last edited by Doright on Sun Nov 28, 2021 10:25 am, edited 1 time in total.
Dennis Barnett
A&P Mechanic, FCC General radio Telephone Operator
Line Maintenance A&P Mechanic and MOC Tech specialist.



Top Contributor
Posts: 1278
Joined: Thu Jan 27, 2011 2:16 pm
PostPosted: Sun Nov 28, 2021 10:17 am
Doright wrote:Well last weekend was stress full Old lady old Pontiac Grand prix tranny bit the dust.
Put it on lift to pull it looked at what I had to do did the math in my head said F it! Not worth fixing sell it or haul to junk yard! Runs good looks ok but not worth effort! too much work lets go buy a new used car......



4t65e trans on a 3800 i assume. those transmissions are notorious for problems.
find a reputable trans shop. one that knows the 4t65 and what needs to be upgraded.have it rebuilt. will outlast the beemer.
worth it if it isnt rotted out.



Top Contributor
Posts: 5543
Joined: Tue Sep 16, 2008 1:17 pm
Location: Pahrump NV.
Country:
USA
PostPosted: Sun Nov 28, 2021 12:18 pm
tomsteve wrote:
Doright wrote:Well last weekend was stress full Old lady old Pontiac Grand prix tranny bit the dust.
Put it on lift to pull it looked at what I had to do did the math in my head said F it! Not worth fixing sell it or haul to junk yard! Runs good looks ok but not worth effort! too much work lets go buy a new used car......



4t65e trans on a 3800 i assume. those transmissions are notorious for problems.
find a reputable trans shop. one that knows the 4t65 and what needs to be upgraded.have it rebuilt. will outlast the beemer.
worth it if it isnt rotted out.


I just don't want to pull it or spend money on a $1000 car thing isnt worth fixing in my opinion, just gonna sell it for parts. Her Jeep is close to being done IF I can ever get the ARP head bolt kit. Leaning towards giving up on Bolts and just going with a Stud kit.
Dennis Barnett
A&P Mechanic, FCC General radio Telephone Operator
Line Maintenance A&P Mechanic and MOC Tech specialist.

User avatar

Top Contributor
Posts: 4733
Joined: Thu Jan 06, 2005 12:15 pm
Location: Canada
PostPosted: Wed Dec 01, 2021 12:31 pm
Too bad that didn't work out. You may end up doing pretty well parting it out but that doesn't solve the problem of needing another car.

We got the TR rear end out yesterday, some really weird engineering there. Took a couple hours not including getting the stuck drum off.
Rob



Top Contributor
Posts: 5543
Joined: Tue Sep 16, 2008 1:17 pm
Location: Pahrump NV.
Country:
USA
PostPosted: Wed Dec 01, 2021 11:53 pm
Got the injectors back today guy came up with others cylinders that had problems than I had expected.... something about 10 and 3 but after cleaning all are well leak free and fire good. I was expecting 7 and 3 where problems.

I ordered two new Delphi coils for problem cylinders they are the makers of the originals from what little research I have done, they come with a 3 year warranty over the elcheapo one I already installed. it came with a 2 year warranty.

Gonna put it back together in morning with new thermostat see how it runs?
After all new plugs 2 new coils cleaned and checked out injectors it only leaves valves pistons wire harness and computer.

If it still misses I will do a compression test eliminate that But I cant waste too much time on it Vett decided to start leaking Oil all over drive way Need to get it on lift and figure out why! 2 foot wide puddle under it after I drove it to town NOT GOOD has me very worried what the heck is wrong? has to be something stupid oil press was good whole time driving it I watch it like a Hawk. Brand new engine what the heck? Told Ol lady no drive car! she didn't like that!

to make matters worse my Hard drive I sent off to get recovered a month ago ... They sent me an email today saying that the hard drive is un recoverable and they were not able to recover any data from it. so no Bit coin for me!
I have a few more drives to check but that one was my best hope. and best guess.
Oh well i tried.
Dennis Barnett
A&P Mechanic, FCC General radio Telephone Operator
Line Maintenance A&P Mechanic and MOC Tech specialist.



Top Contributor
Posts: 5543
Joined: Tue Sep 16, 2008 1:17 pm
Location: Pahrump NV.
Country:
USA
PostPosted: Fri Dec 03, 2021 8:33 am
Well I got the BMW all back together yesterday, Cleaned and flowed full set of injectors new Plugs one new coil on cyl 7 and a new thermostat as I was getting a code for that.

(Note" All injectors went back in their exact same place as removed as I had marked all of them, All coils went back on exact same cylinder they were in as well.)
Originally I had codes for cylinder 7 and occasionally cylinder 3 and the Thermostat code.
cylinder 7 was repeating constantly though as was the thermostat.

It started and ran fine for about a minute then It started miss firing! scanned it, came back with a Misfire on cylinders 8 and 1 ???? What the Heck?
Got it all warmed up cleared codes then it started running fine no codes!
Drove it around a bit with No issues brought home left it for 4 hours then started it again again No issues ran fine.
Just went out and started it again at 3 am true cold start and again Misfiring! haven't scanned it yet but I am expecting 1 & 8 again very curious to find out.

:knockout:

Wire Harness!??? my best guess or I didn't get coils plunged in tight?

I will play with some more in a few hours after the Sun comes up its COLD out their!

Could be something in the warm up program causing this?
BMW dealer was telling me about updates to the engine computer programming that were available that effect drive ability and cold starts. I also read about this on a BMW web forum.
BMW checked the service history for me when I was buying some parts for it and gave me a copy of what BMW has on file for the cars service history, but they said it was incomplete.
They couldn't say whether the updates have been done or not. But I don't think its been done. I also didn't bother to ask how much it would cost to have it done either perhaps I should have?
Dennis Barnett
A&P Mechanic, FCC General radio Telephone Operator
Line Maintenance A&P Mechanic and MOC Tech specialist.



Top Contributor
Posts: 5543
Joined: Tue Sep 16, 2008 1:17 pm
Location: Pahrump NV.
Country:
USA
PostPosted: Fri Dec 03, 2021 10:31 am
Sun is up now, Just went back out their and plugged it into code reader, sure enough miss fire cyl #8 but nothing out of cyl #1 this time.
Allowed it to warm up, cleared codes, restarted it every thing is fine now...... ????

HMMMMM........ GREMLINS!

Intermittent problems are the worst! $#%!@#$%#$$%!! and further more $#@#$$%!!!



:flatten: :knockout:
Dennis Barnett
A&P Mechanic, FCC General radio Telephone Operator
Line Maintenance A&P Mechanic and MOC Tech specialist.

User avatar

Top Contributor
Posts: 4733
Joined: Thu Jan 06, 2005 12:15 pm
Location: Canada
PostPosted: Fri Dec 03, 2021 10:51 am
That has to be frustrating. One of my old trucks had a sensor issue, ran great cold and warm but if you stopped for a few minutes to get something it barely ran when you restarted. The sensor would go back to cold mode even though it was warm.

I'm getting a few more Stang parts today. I went to put the fender on and just realized I don't have front splash shields. I forgot they had completely rotted off to start with. There's always something I forgot.
Rob



Top Contributor
Posts: 5543
Joined: Tue Sep 16, 2008 1:17 pm
Location: Pahrump NV.
Country:
USA
PostPosted: Fri Dec 03, 2021 7:34 pm
Oh I am just having a wonderful day, Went ahead drove the BMW up to Auto parts store and filled it up on gas ran flawlessly even though I didn't do anything except clear codes. Ran over to Orileys to it picked up a another new coil came home and installed it in cylinder 8 then started it again ran same perfect no codes! drove it to drive way in front of house waiting to start it again about 5pm 530 maybe 6 pm longrr the better want a cold start to check it out.

Meanwhile I ran vett over to shop put it on lift see whats going on with oil leak. I checked its oil leval prior to starting it only a quart low. Big puddle for a quart! any way pick it up on lift look at carnage turns out all the oil is coming out front seal! Oil everywhere! from the harmonic balancer or so it appears? NOT GOOD!!!!!!
AC belt was thrown off! and main belt was in middle of Crank pulley! again NOT GOOD!
I cussed for about a half hour maybe an hour and started pulling engine out! It can only be one thing the THRUST BEARING!
I am in middle of pulling it now, oh I so don't want to do this!
I did not need this right now!!!
I am car poor nothing runs reliably right now, but my Ford truck, My Jeep and my VW!

No one want;s to drive my truck its too big and its a gas hog! My Jeep runs but she wont drive it as its all over the road due to Sway bars being removed.
What can I say? Its a trail rig mainly. its great at 40 mph or less anything over 40 mph and its scary even for me! I have to be on my toes when I drive it. drives like drunken sailor on paved roads.

Dam BMW it ran good when I looked at it and test drove it b4 I bought it dm guy screwed me good! I tried to buy others first but prices were to hi ......
I cant win! Dark cloud hasn't left me! not for one minute. every time I think I may be getting ahead.
Dennis Barnett
A&P Mechanic, FCC General radio Telephone Operator
Line Maintenance A&P Mechanic and MOC Tech specialist.



Top Contributor
Posts: 5543
Joined: Tue Sep 16, 2008 1:17 pm
Location: Pahrump NV.
Country:
USA
PostPosted: Tue Dec 07, 2021 9:34 am
BMW is running good after replacing the coil on 8. Wife been driving it around no issues no ck engine Lights, No limp mode any more.
I have to fix the Angle Halo eyes on driver headlight and fix the Parking sensors and replace one of the paddle shifter switches, but it is derivable as is.

Saga continues with the Vett in the process of pulling the engine hope to have it out and on a stand today.
Dennis Barnett
A&P Mechanic, FCC General radio Telephone Operator
Line Maintenance A&P Mechanic and MOC Tech specialist.
PreviousNext

Return to Completed & In Progress Member Projects

Who is online

Users browsing this forum: No registered users and 11 guests